Results 1 to 2 of 2

Thread: Adding bind to server.cfg causes server to instantly close

  1. #1

    Question Adding bind to server.cfg causes server to instantly close

    Hello,

    It's been nearly a decade since I have last played SA:MP and would like to get my server back online for some nostalgia.

    The issue I am having with SACNR is that when I add bind "My External IP" to server.cfg the server opens then instantly closes. And of course when I do not include bind the server opens sucessfully and I can play no problem but SACNR says that is is not functional as bind is missing.

    So either: [11:43:43] [SACNR Monitor] Bind address empty, can't announce server
    or: [11:44:33] Unable to start server on [EXTERNAL IP]. Port in use? followed by a instant closure:

    https://pastebin.com/B4YNVj7P - Log when bind is added

    Here is my server.cfg:

    echo Executing Server Config...
    lanmode 0
    rcon_password [removed]
    maxplayers 100
    port 7777
    bind [My external IP]
    hostname Underground Stunt World 24/7
    gamemode0 SU 1
    filterscripts announce ladmin gate anim anticheat
    announce 1
    chatlogging 1
    query 1
    weburl www.undergroundstunt.co.nr
    maxnpc 0
    onfoot_rate 40
    incar_rate 40
    weapon_rate 40
    stream_distance 300.0
    stream_rate 1000
    maxnpc 0
    plugins streamer.dll Whirlpool.dll sscanf.dll
    logtimeformat [%H:%M:%S]
    language English
    mapname Underground Stunt


    Ports are forwarded and open and others can join my server when bind is not added. Thank you in advance.

  2. #2
    Donating Player Jamie's Avatar
    Join Date
    Jun 2012
    Posts
    1,214
    Rep Power
    1
    Unable to start server on 24.54.82.76:7777. Port in use
    Looks like port 7777 is already in use. Is it possible that you tried to launch two servers?

  3. #3
    Quote Originally Posted by Jamie View Post
    Looks like port 7777 is already in use. Is it possible that you tried to launch two servers?

    Just the one, no matter which port is used. Regardless it seems that even though I do not have the bind in the script the server is still showing up http://monitor.sacnr.com/server-1887714.html so I guess all is well.

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •